0 Flares Filament.io 0 Flares ×

Como actualizar Prestashop 1.5.4 a 1.5.5

 

Hay nueva entrada de como actualizar a la 1.6.  

Acaba de salir la nueva versión (1.5.5) y hemos usado la tienda de ejemplo del curso básico de Prestashop para grabar un video y que veáis lo fácil que es actualizar de una versión a otra.

Os recomiendo que leáis siempre los cambios no la vayamos a liar.  Por ejemplo, de la versión 1.4 a la 1.5 hubo muchísimas modificaciones y había que tener cuidado a la hora de actualizarnos.

Siempre es recomendable antes de hacer nada, realizar una copia de seguridad de la base de datos y de los archivos por lo que pueda ocurrir.   También es OBLIGATORIO revisar que los módulos que usamos son compatibles con la nueva versión y si hemos hecho algún cambio que queramos conservar en el código fuente.

Hemos usado el módulo 1-Click upgrade que el mismo equipo de Prestashop nos proporciona y nos guía en el proceso.

Os dejo el video, donde es más sencillo y visual.

0 Flares Twitter 0 Facebook 0 LinkedIn 0 Email -- Buffer 0 Pin It Share 0 Filament.io 0 Flares ×
34 comentarios
  1. andres Dice:

    Hola, buenos dias.

    He visto algun videotutorial, vuestro. Y bueno te comento haber si me podria hechar un cable. En la tienda online de prestashop, que tengo intente cambiar el Theme y ha hecho un desastre en los modulos y formato de la tienda. La cuestion es que intentado actualizar el prestashop y no me deja, creo que el problema es, por que el que tiene el programa es mi servidor strato, me dice que This tab is an AdminTab, la verdad es que estoy totalmente perdido.

    Gracias.

    Responder
    • ipaelo Dice:

      Buenas,

      He revisado un poco la tienda y es como si tuvieras dos temas mezclados. Prueba a desactivar el modo de desarrollo, a ver si desaparece el mensaje y te deja actualizar.

      Yo sacaría una copia de seguridad y haría una instalación desde cero.

      Saludos

      Responder
  2. andres Dice:

    uffffffff no se ahora me sale otro error, empieza a cargar pero se para y dice; Ajax / Server Error for action backupFiles] textStatus: «error » errorThrown:»Internal Server Error » jqXHR: »
    Creo que hay muchos errores en el servidor, me da la sensacion.

    Si instalo directamente la version nueva, luego todos los productos, categorias, y todas las modificaciones SEO aplicadas como las recupero? Si instalo la copia de seguridad hecha me lo dejara como ahora.
    Tengo otras copias de seguridad pero no se como instalarlas.

    Responder
    • ipaelo Dice:

      No me atrevo a decirte nada sin ver la instalación y el log de errores de PHP, no vaya a ir a peor.

      Puedes hacer un copia en local y ver si tienes los mismos problemas, de este modo puedes ir probando soluciones sin fastidiar la tienda en producción.

      Saludos

      Responder
  3. Ruben Dice:

    Hola Ismael, tengo un proyecto basado en la plataforma prestashop con versión 1.5.5 y estoy intentado actualizar a la 1.5.6 con 1click upgrade. En el proceso me lanza un error, de que no se puede completar la actualización de la DB, y debo restaurarla de nuevo a su versión. Se corta todo el proceso de actualización. ¿Te ha ocurrido en alguna ocasión?, ¿Se te ocurre a priori alguna sugerencia? he probado varias cosillas pero sin éxito. Te mando un saludo y aprovecho para darte las gracias por tus vídeos.

    Responder
      • Ruben Dice:

        Hola de nuevo, perdona por no escribirlo antes. Justo en el proceso de actualización de archivos me lanza este error y se para el proceso «Todos los archivos actualizados. Actualización de base de datos en curso. error al actualizar la DB. Deberá restaurar su base de datos.». Y vuelvo de nuevo a restaurar a la versión original.

        Responder
  4. Miriam Dice:

    Hola, al hacer la nueva actualizacion de 1.5.4.1 a la 1.5.6.0 stable, se queda pausado, me sale unos errores de «error para copiar /Backoffice/ajax-tab.php»,
    «error al intentar actualizar/Backoffice/ajax-tab.php» y
    «/Backoffice/ajaxfilemanager/_ajax_get_details_listing.php no remvidos», y ya no sigue con la actualizacion, alguna sugerencia?

    Responder
    • ipaelo Dice:

      Miriam parece que tienes un problema de permisos con esos archivos y el auto actualizador no es capaz de cambiarlos para poder borrarlos y copiar los nuevos.

      Si lees la guia de Prestahop http://doc.prestashop.com/display/PS15/Installing+PrestaShop

      Debajo tienes las indicaciones correspondientes.

      Log-in to your server account using your FTP client, browse to PrestaShop’s folder, and find the folders that are marked by the installer as in need of a permission change.
      CHMOD
      Icon
      Changing file/folder permission on a Unix/Linux system is called a «CHMOD», after the command of the same name (see: http://en.wikipedia.org/wiki/Chmod – you can find an explanation of file permissions here: http://www.elated.com/articles/understanding-permissions/).
      Giving files or folders a «write permission» is called «doing a CHMOD 755» or «a CHMOD 775», depending on the host.
      Icon
      Some hosts might require you to use CHMOD 777, although it is not recommended for anything more than a one-time need.
      If you have to use CHMOD 777 in order to install PrestaShop, make sure to switch to a safer setting (for instance, 775 for folders and 664 for files) once you are done installing.
      Read your host’s documentation carefully.

      Responder
  5. antoñete Dice:

    Hola! Al entrar en mi sesión me aparece el mensaje:
    «Nueva versión de PrestaShop está disponible : Descargar 1.5.6.0 stable !»
    Descargo el archivo comprimido y lo intento instalar como nuevo módulo, no sé si estoy haciendo lo correcto, ya que me gustaría actualizar la versión sin cambiar el diseño aplicado a la web. EL mensaje que me aparece cuando intento subir el módulo es:
    «Fatal error»
    ¿Alguna ayuda?
    Muchas gracias de antemano 🙂

    Responder
  6. Moises Dice:

    Hola,
    tengo el mismo problema. Me da el error siguiente:
    «error para copiar /Backoffice/ajax-tab.php
    error al intentar actualizar/Backoffice/ajax-tab.php»
    Alguna idea?
    Muchas gracias
    Saludos

    Responder
  7. José Miguel Lázaro Dice:

    Hola he intentado actualizar a la versión 1.5.6.1 y no puedo hacerlo me sale esto en el historial de actividades, si me puedes ayudar, o como hacerlo desde el archivo de la versión nueva que he descargado de prestashop, gracias.

    Analizando la situación …Tienda desactivada. Descargando (esto puede demorar algún tiempo)…
    Error durante la descarga

    download will come from https://www.prestashop.com/download/releases/prestashop_1.5.6.1.zip
    md5 will be checked against 53f2b62cbd414bcc8659215438b5912b
    downloading from https://www.prestashop.com/download/releases/prestashop_1.5.6.1.zip
    file will be saved in C:\Program Files\Xampp\htdocs\prestashop\admin2244\autoupgrade\download\prestashop.zip
    download directory has been emptied
    Error durante la descarga

    Error durante la descarga

    Responder
  8. anva Dice:

    Hola, una pregunta despues de actualizar la versión de prestashop en local, ¿cómo se sube a la web?, ¿se sube directamente por FTP o hay que hacer otra cosa?

    Responder
    • ipaelo Dice:

      Hola Anva,

      ¿Tienes una versión en producción online?. Puedes hacer la actualización en 1-click, una bvez pruebes en local que ningún módulo interfiere en su correcto funcionamiento.

      Si quieres hacerlo de forma manual, puedes seguir este artículo de Victor:

      http://victor-rodenas.com/2013/02/08/guia-migrar-tu-tienda-de-local-a-internet-bajo-la-version-1-5-de-prestashop/

      Ojo, que es para pasar una tienda de local al servidor, no para una actualización.

      Basicamente, es subir los archivos, un dump de la base de datos y después cambiar los datos en el.

      Yo, personalmente hago lo contrario. Hago una copia de seguridad de la tienda y entonces actualizo la tienda online, si no funciona repongo la antigua.

      Responder
  9. ariel Dice:

    hola como estas.. hago todo tal cual y me dice q se actualizo con exito y ningun error… ( en teoria ) … cdo activo la web me sale el siguiente error : Fatal error: Smarty error: the $compile_dir ‘/home/ey000009/public_html/tools/smarty/compile’ does not exist, or is not a directory. in /home/ey000009/public_html/tools/smarty/Smarty.class.php on line 1095
    espero me puedas ayudar… saludos

    Responder
    • ipaelo Dice:

      Hola Ariel,

      Parece que tienes un error de permisos de escritura en el directorio smarty/compile.

      Cambiale los permisos a 755 y si no prueba a 777.

      Saludos

      Responder
  10. zlo Dice:

    Después de actualizar me da el siguiente error:

    Fatal error: Uncaught –> Smarty: Call of unknown method ‘clear_compiled_tpl’. <– thrown in /—/tools/smarty/sysplugins/smarty_internal_templatebase.php on line 858

    ¿Teneis idea de cómo arreglarlo? Gracias

    Responder

Trackbacks y pingbacks

  1. […] recomiendo revisar la entrada de como actualizar de 1.5.X a 1.5.5 o el curso […]

Dejar un comentario

¿Quieres unirte a la conversación?
Siéntete libre de contribuir!

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.